I agree with part of the article, because I didn’t read the rest. I truly dislike the use of single letter variable names: f, g, h and foo, bar, baz. My advice: use descriptive variable names.
function twoIfs, function complicatedIf, var simpleAnd, etc. Makes it so much easier to read examples instead of remembering “oh yeah, f had two ifs in it, h had the if/else, g calls f which calls h which,…”.
Also see this often in other examples: "A for ‘Truthy variable’ " 😓 Wtf. Laziness is good when it makes things easier, not harder.
I agree with part of the article, because I didn’t read the rest. I truly dislike the use of single letter variable names:
f
,g
,h
andfoo
,bar
,baz
. My advice: use descriptive variable names.function twoIfs
,function complicatedIf
,var simpleAnd
, etc. Makes it so much easier to read examples instead of remembering “oh yeah,f
had two ifs in it,h
had the if/else,g
callsf
which callsh
which,…”.Also see this often in other examples: "
A
for ‘Truthy variable’ " 😓 Wtf. Laziness is good when it makes things easier, not harder.The article is really not about naming conventions.
Should have still used them. It was harder to read this way.
The blog author is literally using de-facto standard for placeholder names.
The var names used by the author are perfectly fine. They don’t cause any issue, nor do they make things hard to read.
Doesn’t matter, it’s hard to read an article. If it were hard to read for another reason like bad grammar, I’d comment on that too 🤷